【通达信】顾比到数线主图指标公式002703

N:=60;P:=20;
MA1:EMA(CLOSE,3),COLORYELLOW;
MA2:EMA(CLOSE,5),COLORYELLOW;
MA3:EMA(CLOSE,8),COLORYELLOW;
MA4:EMA(CLOSE,10),COLORYELLOW;
MA5:EMA(CLOSE,12),COLORYELLOW;
MA6:EMA(CLOSE,15),COLORYELLOW;
MA7:EMA(CLOSE,30),COLORRED;
MA8:EMA(CLOSE,35),COLORRED;
MA9:EMA(CLOSE,40),COLORRED;
MA10:EMA(CLOSE,45),COLORRED;
MA11:EMA(CLOSE,50),COLORRED;
MA12:EMA(CLOSE,60),COLORRED;
T1:=CONST(LLVBARS(LOW,N));
T1HIGH:=CONST(REF(HIGH,T1));
CC:=CONST(CURRBARSCOUNT);
T2:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T1)) AND (HIGH>T1HIGH)));
T2HIGH:=CONST(REF(HIGH,T2));
T3:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T2)) AND (HIGH>T2HIGH)));
T3HIGH:=CONST(REF(HIGH,T3));
{猎击线:T3HIGH,LINETHICK2,COLOR0000FF;}
猎击线:DRAWLINE(CURRBARSCOUNT=T3+1, T3HIGH, ISLASTBAR, T3HIGH, 1),LINETHICK2,COLOR0000FF;
DRAWTEXT(ISLASTBAR, T3HIGH, ‘猎击线’)LINETHICK1,COLOR0000FF;
TT1:=CONST(HHVBARS(HIGH,P));
TT1LOW:=CONST(REF(LOW,TT1));
CC1:=CONST(CURRBARSCOUNT);
TT2:=CONST(BARSLAST((CURRBARSCOUNT >CC1+TT1) AND (LOWTT2LOW:=CONST(REF(LOW,TT2));
TT3:=CONST(BARSLAST((CURRBARSCOUNT >CC1+TT2) AND (LOWTT3LOW:=CONST(REF(LOW,TT3));
止损线:DRAWLINE(CURRBARSCOUNT=TT3+1, TT3LOW, ISLASTBAR, TT3LOW,1),LINETHICK2,COLORGREEN;
DRAWTEXT(ISLASTBAR, TT3LOW, ‘止损线’)LINETHICK1,COLORLIGREEN;