【通达信】低位线趋势指标公式002148

VAR1:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
火:=BARSLAST(EMA(CLOSE,5)山:=COUNT(EMA(CLOSE,5)>REF(EMA(CLOSE,5),1),5),NODRAW;
KL:=IF(山>0,2*火,0);
趋势:=KL/2,COLOREE687B,NODRAW;
VARL1:=(EMA(C,12)-EMA(C,26))*100+50;
VARL2:=EMA(VARL1,9);
VARL3:=((HHV(H,21)-C)/(HHV(H,21)-LLV(L,21)))*100-10;
VARL4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VARL5:=SMA(VARL4,13,8);
VARL6:=SMA(VARL3,21,8);
低位线:=IF((趋势-VARL6<(-70)),0,-5);
QS:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
高位线:=IF((QS-VARL6>85),0,-5);
{www.gainiangu.com 概念股网_通达信股票指标公式}
K1:=EMA(VAR2,5),COLORLIBLUE,NODRAW;
K2:=SMA(VAR2,5,1),COLORYELLOW,NODRAW;
K:=EMA((K1-K2),2),COLORWHITE,NODRAW;
KK1:=IF(K>12,90,85);
KK2:=IF(K<-12,80,85);
LC:=REF(CLOSE,1);
VAR01:=C-REF(C,1);
VAR02:=100*EMA(EMA(VAR01,6),6)/EMA(EMA(ABS(VAR01),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),0);
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),0);
BT:(LLV(VAR02,2)=LLV(VAR02,7) AND COUNT(VAR02<0,2) AND CROSS(VAR02,MA(VAR02,2))) AND REF(DOWN,1)REF(DOWN,1);