【通达信】卖三高指标公式股票600778

STICKLINE(C>0,55,-15,15,0),COLOR8C7853;
基准:=TROUGHBARS(1,3,1)=0;
距:BARSLAST(基准),NODRAW;
高:=REF(H,BARSLAST(基准));
低点:REF(L,BARSLAST(基准)),NODRAW;
涨幅:(C-低点)/低点*100,NODRAW;
涨幅H:(H-低点)/低点*100,NODRAW;
高1:=H>高+0.02 AND 距>0 ,NODRAW;
A2:=高1*距,NODRAW;
A3:=COUNT(高1,距),NODRAW;
一高:=IF(A3>1,A3=1,A2),COLORWHITE,NODRAW;
STICKLINE(一高,55,45,2,0)COLORRED;
距1:=BARSLAST(一高),NODRAW;
B1:=REF(H,距1=1)+0.02 ,COLORWHITE,NODRAW;
引高二:=IF(一高 OR 距1>距,1000,B1),COLORWHITE,NODRAW;
高2:=H>引高二 AND 距>=2 AND 距1<距 ,NODRAW;
B2:=高2*距,NODRAW;
B3:=COUNT(高2,距),NODRAW;
二高:=IF(B3>1,B3=1,B2),COLORWHITE,NODRAW;
STICKLINE(二高,55,45,2,0)COLORRED;
STICKLINE(二高,35,45,2,0)COLORGREEN;
{ 概念股网_通达信股票指标公式}
距2:=BARSLAST(二高),NODRAW;
价3:=REF(H,距2=1)+0.02 ,COLORWHITE,NODRAW;
引高三:=IF(一高 OR 二高 OR 距<距2 , 1000,价3),COLORWHITE,NODRAW;
高3:=H>引高三 AND 距1<距 AND 距2<距1 AND 距>=3 ,NODRAW;
C2:=高3*距,NODRAW;
C3:=COUNT(高3,距),NODRAW;
三高:=IF(C3>1,C3=1,C2),COLORWHITE,NODRAW;
STICKLINE(三高,45,55,2,0)COLORRED;
STICKLINE(三高,35,45,2,0)COLORGREEN;
STICKLINE(三高,25,35,2,0)COLORYELLOW;