【大智慧】太极至尊主图指标公式600976股票

{均线系统}
MA3:MA(C,3),COLORWHITE;
MA5:MA(C,5),COLORYELLOW;
MA10:MA(C,10),COLORMAGENTA;
MA20:MA(C,20),COLORGREEN;
MA30:MA(C,30),COLORRED;
MA60:MA(C,60),COLORBLUE;
MA120:MA(C,120),COLOR3791B5;
MA240:MA(C,240),COLORCYAN;
三日斜率:=ATAN(100*(MA3/REF(MA3,1)-1))*180/3.1416;
三日涨幅:=(C-REF(C,3))/REF(C,3)*100;
最高价比:=(C/HHV(H,0))*100;
{突破点参考}
TPD:=CROSS(C,REF(HIGH,BARSLAST(CROSS((BACKSET(REF(HIGH,2)=HHV(HIGH,5),3)),0.9)))) ;
{概念股网-股票公式网站 }
DRAWTEXT(TPD,(L * 0.96),’★’),COLORYELLOW;
{涨跌停板显示}
ZDF:=(C-REF(C,1))/REF(C,1)*100 ;
STICKLINE(ZDF>9.8,O,C,8,0),COLORRED;
STICKLINE(ZDF<-9.8,O,C,8,0),COLORBLUE;
{ST涨跌停板显示}
STZDF:=(C-REF(C,1))/REF(C,1)*100 ;
STICKLINE(STZDF>4.8 AND STRFIND(stkname,’S’,1)>0,O,C,8,0),COLORRED;
STICKLINE(STZDF<-4.8 AND STRFIND(stkname,'S',1)>0,O,C,8,0),COLORBLUE;
{财务指标}
DRAWTEXTABS(0,10,’【★太极至尊★】’),colorred;
DRAWTEXTABS(0,40,’【所属板块】:’+BKNAME),colorwhite;
DRAWTEXTABS(100,10,’市盈:’+NUMTOSTRN(DYNAINFO(39),2)+’ 市净:’+NUMTOSTRN(DYNAINFO(58),2)+’ 净资:’+NUMTOSTRN(FINANCE2(4),2)
+’ 收益:’+NUMTOSTRN(FINANCE2(3),2)+’ 收益率:’+NUMTOSTRN(FINANCE2(5),2)+’%’+’ 净利润同比:’+NUMTOSTRN(FINANCE2(10),2)),colorred;
DRAWTEXTABS(0,25,’【三日斜率】:’+NUMTOSTRN(三日斜率,2)
+’ 【三日涨幅】:’+NUMTOSTRN(三日涨幅,2)+’%’+’ 【最高价比】:’+NUMTOSTRN(最高价比,2)
+’ 【获利比例】:’+NUMTOSTRN(WINNERB(C)*100,2)+’%’+’ 【流通股】:’+NUMTOSTRN(FINANCE2(37),0)),colorred;
{阻力线和支撑线}
A1:=BACKSET(REF(H,2)=HHV(H,5),3);
A2:=BACKSET(REF(L,2)=LLV(L,5),3);
A3:=CROSS(A1,0.9);
A4:=CROSS(A2,0.9);
压力:REF(H,BARSLAST(A3)),POINTDOT,COLOREA91B5;
支撑:REF(L,BARSLAST(A4)),POINTDOT,COLOR3791B5;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(A3)),REF(HIGH,BARSLAST(A3)),5,0),ColorEA91B5;
STICKLINE(CLOSE,REF(LOW,BARSLAST(A4)),REF(LOW,BARSLAST(A4)),5,0),Color3791B5;