【通达信】追日骑月指标公式601988中国银行

A:=C追日:BARSLAST(A),COLORRED;
AAZ:STICKLINE(追日=0,-5,0,1,1),COLORGREEN;
LS11:=IF(1,追日=1,A);
LS21:=IF(1,LLV(L,1)>REF(L,1),1);
A1:IF(LS11 AND LS21,1,0);
LS12:=IF(2,追日=2,A);
LS22:=IF(2,LLV(L,2)>REF(L,2),1);
A2:IF(LS12 AND LS22,2,0);
LS13:=IF(3,追日=3,A);
LS23:=IF(3,LLV(L,3)>REF(L,3),1);
A3:IF(LS13 AND LS23,3,0);
LS14:=IF(4,追日=4,A);
LS24:=IF(4,LLV(L,4)>REF(L,4),1);
A4:IF(LS14 AND LS24,4,0);
LS15:=IF(5,追日=5,A);
LS25:=IF(5,LLV(L,5)>REF(L,5),1);
A5:IF(LS15 AND LS25,5,0);
LS16:=IF(6,追日=6,A);
LS26:=IF(6,LLV(L,6)>REF(L,6),1);
A6:IF(LS16 AND LS26,6,0);
LS17:=IF(7,追日=7,A);
LS27:=IF(7,LLV(L,7)>REF(L,7),1);
A7:IF(LS17 AND LS27,7,0);
LS18:=IF(8,追日=8,A);
LS28:=IF(8,LLV(L,8)>REF(L,8),1);
A8:IF(LS18 AND LS28,8,0);
LS19:=IF(9,追日=9,A);
LS29:=IF(9,LLV(L,9)>REF(L,9),1);
A9:IF(LS19 AND LS29,9,0);
AA:=C>REF(H,4);
骑月:BARSLAST(AA),COLORGREEN;
AAA:STICKLINE(骑月=0,-5,0,1,1),COLORLIRED;
ALS11:=IF(1,骑月=1,AA);
ALS21:=IF(1,HHV(H,1)AA1:IF(ALS11 AND ALS21,1,0);
ALS12:=IF(2,骑月=2,AA);
ALS22:=IF(2,HHV(H,2)AA2:IF(ALS12 AND ALS22,2,0);
ALS13:=IF(3,骑月=3,AA);
ALS23:=IF(3,HHV(H,3)AA3:IF(ALS13 AND ALS23,3,0);
ALS14:=IF(4,骑月=4,AA);
ALS24:=IF(4,HHV(H,4)AA4:IF(ALS14 AND ALS24,4,0);
ALS15:=IF(5,骑月=5,AA);
ALS25:=IF(5,HHV(H,5)AA5:IF(ALS15 AND ALS25,5,0);
ALS16:=IF(6,骑月=6,AA);
ALS26:=IF(6,HHV(H,6)AA6:IF(ALS16 AND ALS26,6,0);
ALS17:=IF(7,骑月=7,AA);
ALS27:=IF(7,HHV(H,7)AA7:IF(ALS17 AND ALS27,7,0);
ALS18:=IF(8,骑月=8,AA);
ALS28:=IF(8,HHV(H,8)AA8:IF(ALS18 AND ALS28,8,0);
ALS19:=IF(9,骑月=9,AA);
ALS29:=IF(9,HHV(H,9)AA9:IF(ALS19 AND ALS29,9,0);
DRAWICON(AA9=9,10,1);
STICKLINE(追日>0 AND 骑月>0,-5,0,1,0),COLORYELLOW;
9;