【大智慧】MACD优指标公式吉林森工股票

DIF:(EMA(C,5)-EMA(C,21))/EMA(C,21)*100,ColorF0F0F0;
DEA:EMA(DIF,8),COLOR00DCDC;
MACD:2*(DIF-DEA),COLOR0000DC,LINETHICK0;
STICKLINE(MACD>0,MACD,0,8,1),COLOR0000DC;
STICKLINE(MACD>0 AND MACDSTICKLINE(MACD<=0,MACD,0,8,1),COLORGRAY;
STICKLINE(MACD<=0 AND MACD>REF(MACD,1),MACD,0,8,1),COLORC800C8;
X0:=BARSLAST((CROSS(MACD,REF(MACD,1)) AND MACD>0) OR CROSS(MACD,0));
X1:=BARSLAST(CROSS(0.5,COUNT(MACD>REF(MACD,1),X0+1)=X0+1));{回}
X2:=COUNT(MACDX3:=REF(X2,1) AND MACD>REF(MACD,1) AND C>O AND C>REF(C,1);
STICKLINE(X1=0 AND MACD>0,MACD,0,8,0),ColorDCDC00;
STICKLINE(X3,MACD,0,8,0),Color0854FF;
POLYLINE(C>0,DIF),ColorF0F0F0;
POLYLINE(C>0,DEA),COLOR00DCDC;
PARTLINE(DIF,DIF>REF(DIF,1)),COLORRED,LAYER0;
ER:=VOL/CAPITAL*100;
ZD:=C/REF(C,1)*100-100;

A0:=BARSLAST(CROSS(0.5,COUNT(MACD<0,3)>=3) AND (MACD>=1 OR DIF>=2));
A1:=CROSS(0.5,COUNT(MACD>REF(MACD,1),A0+1)=A0+1);
A2:=REF(HHV(ER,A0+1),1)>=3 AND REF(HHV(ZD,A0+3),1)>=5;
B0:=BARSLAST(A1 AND A2);
B1:=COUNT(MACDB2:=COUNT(MACD<0,B0+1)<=2 AND (COUNT(C=1);
B3:=B1 AND B2;
B4:=REF(B3,1) AND MACD>REF(MACD,1) AND C>O AND ZD>0;
DRAWTEXT(B4,ABS(MACD)+1.5,’◆’),COLORYELLOW,align1;