【通达信】鹰眼判势主图指标公式600990股票

A1:=C*2-REF(C,8.5/2);
A2:=REF(C,19/3)*2-C;
短期对称:=(A1+A2)/2;
关键点:=HHV(短期对称,27/2);
M1:=L*2-REF(H,27/2);
M2:=REF(H,27/2)*2-L;
M3:=(M1+M2)/2;
中期对称:=FORCAST(M3,21);
趋势判断:MA(M3,27*2),COLOR0000FF,NODRAW;
VAR5:=EMA((O+H+L+C)/4,233);
鹰派审美观:=VAR5+VAR5*6/100;
AMV0:=V*(O+C)/2;
{概念股网-股票公式网站 www.gupanG.com}
朦胧才是美:=SUM(AMV0,45.5)/SUM(V,45.5);
CG:=MA(C,12.5);
FL:=HHV(CG,9);
FS:=CG-FL-CG;
ZA5:=趋势判断-REF(趋势判断,1);
{DRAWICON(ZA5<0,趋势判断,1);
DRAWICON(ZA5>0,趋势判断,10);
DRAWICON(ZA5=0,趋势判断,2);}
{通达信版}
IF(ZA5<0,趋势判断,DRAWNULL),COLOR00FF00,POINTDOT,LINETHICK4;
IF(ZA5>0,趋势判断,DRAWNULL),COLOR0000FF,POINTDOT,LINETHICK4;
IF(ZA5=0,趋势判断,DRAWNULL),COLOR00FFFF,POINTDOT,LINETHICK4;
{通用版}
{DRAWTEXT(ZA5<0,趋势判断,'●'),COLOR00FF00;
DRAWTEXT(ZA5>0,趋势判断,’●’),COLOR0000FF;
DRAWTEXT(ZA5=0,趋势判断,’●’),COLOR00FFFF;}
STICKLINE(C>=CG,O,C,2.5,0),COLOR0000FF;
STICKLINE(C>=CG,L,O,0,1),COLOR0000FF;
STICKLINE(C>=CG,C,H,0,1),COLOR0000FF;
STICKLINE(CSTICKLINE(CSTICKLINE(CH1:=HHVBARS(A1,13);
HB:=HHVBARS(A1,4.5);
短线判断:REF(短期对称,HB),COLORFFFF00;
中线判断:REF(M3,H1),COLOR00FFFF;