【通达信】麒麟抄底指标公式002586

VARA:=BARSCOUNT(CLOSE)*3.142/180;
A2: SIN(VARA*8)*100,LINETHICK2;
A3: COS(VARA*8)*100,LINETHICK2;
X1: 0;
VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3:=MA(CLOSE,20);
VAR4:=MA(CLOSE,30);
VAR5:=(VAR1+VAR2+VAR3+VAR4)/4;
VAR6:=(VAR5-REF(VAR5,5))/REF(VAR5,5)*1500;
VAR7:=(VAR5-REF(VAR5,5))/REF(VAR5,5)*1500;
VAR8:=EMA(VAR6,8);
{概念股网-股票公式网站 www.guPang.com}
注意: STICKLINE(VAR6>REF(VAR6,1) AND VAR6<0 AND VAR6转强: STICKLINE(VAR8>REF(VAR8,1) AND VAR6<0 AND VAR6>VAR8,VAR8,0,5,0),COLORYELLOW;
买点: STICKLINE(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,VAR6,VAR8,10,0);
DRAWICON(FILTER(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,30),-140,4);
DRAWTEXT(FILTER(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,30),-40,'买点'),COLORFFFFFF;
持股: STICKLINE(VAR8>REF(VAR8,1) AND VAR8>0,VAR6,0,5,0),COLORRED;
观望: STICKLINE(VAR6REF(VAR8,1) AND VAR6>0,VAR6,VAR8,10,0);
持币: STICKLINE(VAR6VAR9:=TROUGHBARS(3,15,1)<10;
VAR10:=PEAKBARS(3,15,1)<10;
VAR11:=IF(VAR9=1,50,0);
VAR12:=IF(VAR10=1,50,0);
底部:= IF(VAR11=50,50,0);
头部:= IF(VAR12=50,100,0);
A:IF( 底部>REF(底部,1),50,0);
AA:IF(头部>REF(头部,1),50,0);
DRAWTEXT(A=50,100,’买’ ),COLORRED,LINETHICK2;
DRAWTEXT(AA=50,100,’卖’),COLOR00FF00,LINETHICK2;
注意底部:0,COLORFFFFFF;
低位转强:0,COLORYELLOW;
坚决持股:0,COLORRED;
谨慎观望:0,COLOR400080;
果断持币:0,COLORFFFF00;